Need to Know

Instructor-Led Courses

All instructor-led course start times are in the Central Standard time zone and are held via Zoom. If you haven't used Zoom before, we recommend that you download it in advance at zoom.us.


PSU Connect

Prior to PSU Remote Plus, join PSU Connect--a social networking community just for PowerSchool University! Network with attendees from across the country, share ideas with users from your state or a similar district, and participate in online discussions. PSU Connect is also your source for "Talks with Ted" featuring Ted Lindquist, everyone's favorite PSU emcee sharing all the latest updates. Registered attendees will receive details on how to join closer to the start of the event.


CEUs

Most PSU instructor-led classes are eligible for Continuing Education Units (CEUs). Watch for more details on how to obtain your CEUs as we approach the event. 


PSU Remote Plus Limited Edition Souvenir

As part of your PSU Remote Plus registration, you can sign up to receive a limited edition PSU Remote Plus souvenir.  More details on the souvenir to come. 

To get your souvenir, go to My Events, then My Registrations, and click Souvenir under Exclusives. All attendees must make an election on receiving your souvenir, even if you opt out.


PD+

As a part of PSU Remote Plus, you'll receive access to PD+ for two months. PD+ is our online, self-paced eLearning training platform. Learn more about PD+.


Technical Requirements

If you have any concerns about these requirements, please email psu@powerschool.com.

Macintosh Requirements

  • Intel Core 2 Duo+
  • 2 GB RAM
  • Mac OS 10.12+ Sierra
  • Office 2016
  • 1 GB available disk space
  • 54 Mbps or faster Wireless Network Capability
  • Java 1.8.0_131 (Java 8)
  • Chrome 87+
  • Administrative access
  • 5 GHz network band capability (Preferred)

Windows Requirements

  • Intel P4 or AMD equivalent
  • 2 GB RAM
  • Windows 7+
  • Office 2016
  • 1 GB available disk space
  • 54 Mbps or faster Wireless Network Capability
  • Java 1.8.0_131 (Java 8)
  • Chrome 87+
  • Administrative access
  • 5 GHz network band capability (Preferred)

Please note: Java 1.8.0_131 (or higher) is required for SQL Developer 18.2 software utilized in Customizations Courses 201, 202, 301 and 350. The Chrome extension BigConsole is also recommended for Customizations courses.